arpad@arpad-P170EM:~$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
arpad@arpad-P170EM:~$

arpad@arpad-P170EM:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK104M [GeForce GTX 675MX] (rev a1)
arpad@arpad-P170EM:~$

arpad@arpad-P170EM:~$ sudo apt install nvidia-driver-410
[sudo] password for arpad:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
nvidia-driver-410 : Depends: libnvidia-gl-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Depends: nvidia-dkms-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Depends: nvidia-kernel-source-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-compute-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Depends: nvidia-compute-utils-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-decode-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-encode-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Depends: nvidia-utils-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-ifr1-410 (= 410.78-0ubuntu1~gpu18.04.1) but it is not going to be installed
Recommends: libnvidia-compute-410:i386 (= 410.78-0ubuntu1~gpu18.04.1)
Recommends: libnvidia-decode-410:i386 (= 410.78-0ubuntu1~gpu18.04.1)
Recommends: libnvidia-encode-410:i386 (= 410.78-0ubuntu1~gpu18.04.1)
E: Unable to correct problems, you have held broken packages.
arpad@arpad-P170EM:~$

 

fix broken packages menüben, utána ezt írta

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

 

arpad@arpad-P170EM:~$ glxinfo | grep OpenGL
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
arpad@arpad-P170EM:~$