[root@crm-example-com oroapp]# composer require oro/mailchimp --prefer-dist --update-no-dev
Using version ^1.1 for oro/mailchimp
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: remove oro/crm 4.0.0
- Conclusion: don't install oro/crm 4.0.0
- Conclusion: don't install oro/crm 4.0.0
- oro/mailchimp 1.1.0 requires oro/crm 3.1.* -> satisfiable by oro/crm[3.1.x-dev].
- oro/mailchimp 1.1.1 requires oro/crm 3.1.* -> satisfiable by oro/crm[3.1.x-dev].
- Can only install one of: oro/crm[3.1.x-dev, 4.0.0].
- Can only install one of: oro/crm[3.1.x-dev, 4.0.0].
- Installation request for oro/crm (locked at 4.0.0, required as 4.0.*) -> satisfiable by oro/crm[4.0.0].
- Installation request for oro/mailchimp ^1.1 -> satisfiable by oro/mailchimp[1.1.0, 1.1.1].

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

Installation failed, reverting ./composer.json to its original content.